Skip navigation

Torno a parlare di OpenSuSE e precisamente della nuova release 11.1.

Visto che non ricordo se l’ho detto nell’articolo precedente,premetto che il pc su cui gira la OS 11.1, è un notebook L30 Toshiba con bios Phoenix, Ati Xpress 200m e 1gb Ram.

La prima cosa che mi salta agli occhi dopo l’installazione della 11.1 è stata la correzione di un bug del kernel presente nella 11.0 (2.6.26) che impediva al mio portatile l’uso dello ACPI e che doveva essere corretto a mano editando alcuni files nei sorgenti del kernel e ricompilando ma ci volevano un paio d’ore . Miglioria quest’ultima che ha influito felicemente anche sulla gestione corretta della scheda wireless.

La versione del kernel che viene installata di default e la 2.6.27.7-9-pae che sinceramente ritengo inadeguata. Difatti, visto il target sempre più “end-user” che hanno riscosso le distribuzioni linux, preferisco installare il kernel-default che ritengo più snello e rapido.

Nello specifico per il mio portatile è necessario installare anche il supporto “omnibook”, inizialmente creato per i notebook HP e poi scoperto utile anche per altri “Brand” di notebook, perchè come specificavo prima e non a caso, il bios del mio laptop non è un toshiba “puro” ma un phoenix.

La prima problematica che ho dovuto affrontare, è stato il settaggio della scheda video per poter abilitare Compiz sotto Gnome. Dopo aver scaricato i driver dai repository ATI (qui la pagina ufficiale con i repositories da poter aggiungere a YaST ) ho dovuto ovviare a dei problemini nel modo descritto in questa pagina e che è legata soprattutto alle schede ATI della serie Radeon Xpress.

Ora che compiz è abilitato, c’è sempre il solito problema con la riproduzione dei video (dopo aver chiaramente installato i codec e gli applicativi vari. Googlate gente, ..googlate!) che si presentava anche con la release 11.0; sarebbe a dire che si sente l’audio ma il video non si vede. Si risolve aprendo xine, impostazioni, video e impostando il “driver video da usare ” su xshm (se non riuscite a farlo, assicuratevi che nel tab “GUI” alla voce “configurazione del livello di esperienza” sia settato su “master of the know universe“; se non lo è, settatelo, riavviate xine e procedete come sopra). Completiamo il tutto settando anche GStreamer; apriamo una consolle e digitiamo gstreamer-properties, si aprirà una finestra e andando sul tab video nella sezione Uscita predefinita, scegliamo come plug-in “X Windows System (senza Xv)“. Chiudiamo e ora dovrebbero potersi visualizzare i video.

fine prima parte.

(non mi va più per oggi)

Annunci

Rispondi

Effettua il login con uno di questi metodi per inviare il tuo commento:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...